Thursday, August 2, 2007

Cisco DDR Configuration

Following are some of the key points in configuring Cisco DDR on Cisco router.

DDR Legacy Concepts and Configuration

Step 1: Routing Packets Out the Interface to be Dialed
ip route 192.168.0.0 255.255.255.0 10.0.0.1
Step 2: Determining the Subset of the Packets That Trigger the Dialing Process
access-list 101 permit tcp any host 192.168.0.1 eq 80

! all ip packets being considered interesting
dialer-list 1 protocol ip permit

! all packets to the web servers consider interesting
dialer-list 2 protocol ip list 101

interface bri 0
encapsulation ppp
ip address 10.0.0.2 255.255.255.0

! Use this one if all ip is considered interesting
dialer-group 1

! or use next statement to trigger for web to server ! if you type the next command, it would replace the dialer-group 1
! command; only one dialer-group is allowed per interface
dialer-group 2

Step 3: Dialing (Signaling)
One site:
=========
interface bri 0
encapsulation ppp
dialer string 818186666 <- the phone number that is to be used to signal a connection
ip address 10.0.0.2 255.255.255.0
! Use this one if all ip is considered interesting
dialer-group 1
Multi sites:
============
interface bri 0
encapsulation ppp
ip address 10.0.0.2 255.255.255.0
! Use this one if all ip is considered interesting
dialer map ip 192.168.0.1 broadcast name KL 1800111111
dialer map ip 192.168.0.2 broadcast name Sing 1899933488
dialer-group 1

No comments:

Post a Comment